Issue with duplicate emails being sent
Incident Report for Cryptolens AB
Resolved
Yesterday at around 4:11 PM-4:20 PM (UTC), some users received the same email 20 times. The issue seems to be with our third party provider that we use to as a relay for SMTP traffic. We are actively working on finding a way to solve this.
Posted Jun 09, 2020 - 18:00 CEST